incident.io Test

Platform services unavailable
Resolved·Degraded performance

Testing

Tue, Oct 14, 2025, 05:14 AM
(1 month ago)
·
Affected components
Website portal
Updates

Resolved

Testing

Tue, Oct 14, 2025, 05:14 AM

Identified

Our trading platforms are experiencing technical issues.
We’re working to restore normal services as soon as possible.

For urgent queries, contact us via live chat.

Tue, Oct 14, 2025, 05:07 AM
Powered by

Notifications are sent to subscribers via Incident.io. Certain platforms on this page may not be available in your region.