Resolved
The issue has been resolved. You can continue using our services as usual.
Need help? Our support team is available 24/7 via live chat.
Identified
TEST:
Our live chat support is experiencing technical issues.
We're working to get it back online as soon as possible.
For urgent queries, email us at support@deriv.com.
Notifications are sent to subscribers via Incident.io. Certain platforms on this page may not be available in your region.